summaryrefslogtreecommitdiff
path: root/modules/common/documentation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/documentation.nix')
-rw-r--r--modules/common/documentation.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/modules/common/documentation.nix b/modules/common/documentation.nix
new file mode 100644
index 0000000..20856cb
--- /dev/null
+++ b/modules/common/documentation.nix
@@ -0,0 +1,40 @@
+{
+ config,
+ lib,
+ pkgs,
+ this,
+ ...
+}:
+with lib;
+{
+ config = {
+ hm.manual = {
+ manpages.enable = this.isHeadful;
+ html.enable = false;
+ json.enable = false;
+ };
+
+ documentation = {
+ enable = this.isHeadful;
+ dev.enable = true;
+ doc.enable = false;
+ info.enable = false;
+ nixos.enable = true;
+
+ man.man-db.manualPages =
+ (pkgs.buildEnv {
+ name = "man-paths";
+ paths = with config; environment.systemPackages ++ hm.home.packages;
+ pathsToLink = [ "/share/man" ];
+ extraOutputsToInstall = [ "man" ];
+ ignoreCollisions = true;
+ }).overrideAttrs
+ (_: _: { __contentAddressed = true; });
+ };
+
+ environment.sessionVariables = {
+ MANOPT = "--no-hyphenation";
+ MANPAGER = "${getExe pkgs.less} -+F";
+ };
+ };
+}