summaryrefslogtreecommitdiff
path: root/modules/common/editorconfig.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/editorconfig.nix')
-rw-r--r--modules/common/editorconfig.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/modules/common/editorconfig.nix b/modules/common/editorconfig.nix
index 822acf6..537912f 100644
--- a/modules/common/editorconfig.nix
+++ b/modules/common/editorconfig.nix
@@ -29,7 +29,7 @@ in {
};
# https://go.dev/doc/effective_go#formatting
- "*.go" = {
+ "{*.go,go.mod}" = {
indent_size = 2;
indent_style = "tab";
};
@@ -66,7 +66,7 @@ in {
indent_style = "space";
};
- "*.{asm,s}" = {
+ "*.{asm,s,S}" = {
indent_size = 4;
indent_style = "spaces";
};
@@ -90,6 +90,12 @@ in {
indent_style = "space";
};
+ # https://nickel-lang.org/user-manual/syntax
+ "*.ncl" = {
+ indent_size = 2;
+ indent_style = "space";
+ };
+
# https://developer.hashicorp.com/terraform/language/syntax/style
"*.{tf,hcl}" = {
indent_size = 2;