summaryrefslogtreecommitdiff
path: root/modules/common/eza.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/eza.nix')
-rw-r--r--modules/common/eza.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/modules/common/eza.nix b/modules/common/eza.nix
index be590b4..96b7d4c 100644
--- a/modules/common/eza.nix
+++ b/modules/common/eza.nix
@@ -4,9 +4,11 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.eza;
-in {
+in
+{
options.nixfiles.modules.eza.enable = mkEnableOption "eza, an alternative to ls";
config = mkIf cfg.enable {
@@ -16,6 +18,6 @@ in {
la = "${ll} --header --all";
};
- hm.home.packages = [pkgs.eza];
+ hm.home.packages = [ pkgs.eza ];
};
}