summaryrefslogtreecommitdiff
path: root/modules/common/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/git.nix')
-rw-r--r--modules/common/git.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/common/git.nix b/modules/common/git.nix
index 70fb7c7..de401fb 100644
--- a/modules/common/git.nix
+++ b/modules/common/git.nix
@@ -68,6 +68,7 @@ in {
submodule = "log";
};
init.defaultBranch = "master";
+ push.autoSetupRemote = true;
status.submoduleSummary = true;
github.user = my.username;
gitlab.user = my.username;
@@ -96,6 +97,11 @@ in {
in {
fuck = "!${git} reset --hard && ${git} clean -fdx";
gud = ''commit -m "git gud"'';
+ review = "!${git} lg @{push}..";
+ reword = "commit --amend";
+ tree = "log --graph --date=relative --pretty=tformat:'%Cred%h%Creset -%C(auto)%d%Creset %s %Cgreen(%an %ad)%Creset'";
+ uncommit = "reset --soft HEAD~1";
+ untrack = "rm --cache --";
wtc = "!${curl} -sq whatthecommit.com/index.txt | ${git} commit -F -";
};