summaryrefslogtreecommitdiff
path: root/modules/common/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/nix.nix')
-rw-r--r--modules/common/nix.nix31
1 files changed, 8 insertions, 23 deletions
diff --git a/modules/common/nix.nix b/modules/common/nix.nix
index 233edda..01b3f01 100644
--- a/modules/common/nix.nix
+++ b/modules/common/nix.nix
@@ -61,14 +61,15 @@ in
notSelfInputs = filterAttrs (n: _: n != "self") inputs;
in
{
- daemonCPUSchedPolicy = "idle";
- daemonIOSchedClass = "idle";
- daemonIOSchedPriority = 7;
+ nixPath = mapAttrsToList (n: v: "${n}=${v}") notSelfInputs ++ [
+ "nixfiles=${config.my.home}/src/nixfiles"
+ ];
- settings = {
- keep-derivations = if this.isHeadful then "true" else "false";
- keep-outputs = if this.isHeadful then "true" else "false";
+ registry = mapAttrs (_: flake: { inherit flake; }) notSelfInputs // {
+ nixfiles.flake = inputs.self;
+ };
+ settings = {
warn-dirty = false;
keep-going = true;
@@ -86,28 +87,12 @@ in
my.username
];
};
-
- nixPath = mapAttrsToList (n: v: "${n}=${v}") notSelfInputs ++ [
- "nixfiles=${config.my.home}/src/nixfiles"
- ];
-
- registry = mapAttrs (_: flake: { inherit flake; }) notSelfInputs // {
- nixfiles.flake = inputs.self;
- };
};
nixpkgs = {
config.allowUnfreePredicate = p: elem (getName p) cfg.allowedUnfreePackages;
- overlays = with inputs; [
- self.overlays.default
- # (_: _prev: with packages; {
- # # Global PR package overrides go here. Example:
- # # ```
- # # inherit (package.formPR 309018 "sha256-x3ATxjrTVdaX5eo9P6pz+8/W6D2TNYzvjZpOBa3ZRI8=") endlessh-go;
- # # ```
- # })
- ];
+ overlays = [ inputs.self.overlays.default ];
};
environment = {