summaryrefslogtreecommitdiff
path: root/modules/common/password-store.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/password-store.nix')
-rw-r--r--modules/common/password-store.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/modules/common/password-store.nix b/modules/common/password-store.nix
deleted file mode 100644
index e5cd756..0000000
--- a/modules/common/password-store.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.password-store;
-in
-{
- options.nixfiles.modules.password-store.enable = mkEnableOption "the standard UNIX password manager";
-
- config = mkIf cfg.enable {
- hm.programs = {
- password-store = {
- enable = true;
-
- package = pkgs.pass.withExtensions (p: with p; [ pass-otp ]);
-
- settings.PASSWORD_STORE_DIR = "${config.my.home}/.password-store";
- };
-
- # HACK https://github.com/NixOS/nixpkgs/issues/183604
- bash.initExtra =
- let
- completions = "${config.hm.programs.password-store.package}/share/bash-completion/completions";
- in
- mkAfter ''
- source ${completions}/pass-otp
- source ${completions}/pass
- '';
- };
- };
-}