summaryrefslogtreecommitdiff
path: root/modules/common/profiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/default.nix')
-rw-r--r--modules/common/profiles/default.nix48
1 files changed, 4 insertions, 44 deletions
diff --git a/modules/common/profiles/default.nix b/modules/common/profiles/default.nix
index 2b24752..a17ff08 100644
--- a/modules/common/profiles/default.nix
+++ b/modules/common/profiles/default.nix
@@ -13,53 +13,13 @@ in {
./email.nix
./headful.nix
./headless.nix
- (mkAliasOptionModule ["colourScheme"] [
- "nixfiles"
- "modules"
- "profiles"
- "default"
- "colourScheme"
- ])
];
- options.nixfiles.modules.profiles.default = {
- enable =
- mkEnableOption "The most default profile of them all."
- // {
- default = true;
- };
-
- colourScheme = let
- mkColour = default:
- mkOption {
- type = types.str;
- inherit default;
- description = "Colour in a standard hexadecimal notation.";
- example = "#000000";
- };
- in rec {
- black = mkColour "#161719";
- red = mkColour "#cc6666";
- green = mkColour "#b5bd68";
- yellow = mkColour "#f0c674";
- blue = mkColour "#81a2be";
- magenta = mkColour "#b294bb";
- cyan = mkColour "#8abeb7";
- white = mkColour "#c5c8c6";
-
- brightBlack = mkColour "#969896";
- brightRed = mkColour "#cc6666";
- brightGreen = mkColour "#b5bd68";
- brightYellow = mkColour "#f0c674";
- brightBlue = mkColour "#81a2be";
- brightMagenta = mkColour "#b294bb";
- brightCyan = mkColour "#8abeb7";
- brightWhite = mkColour "#ffffff";
-
- background = black;
- foreground = white;
+ options.nixfiles.modules.profiles.default.enable =
+ mkEnableOption "The most default profile of them all."
+ // {
+ default = true;
};
- };
config = mkIf cfg.enable {
assertions = [