summaryrefslogtreecommitdiff
path: root/modules/common/profiles/dev/containers.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/dev/containers.nix')
-rw-r--r--modules/common/profiles/dev/containers.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/modules/common/profiles/dev/containers.nix b/modules/common/profiles/dev/containers.nix
deleted file mode 100644
index 8f3bfc6..0000000
--- a/modules/common/profiles/dev/containers.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.profiles.dev.containers;
-in
-{
- options.nixfiles.modules.profiles.dev.containers.enable =
- mkEnableOption "Tools for working with containers and container orchestration"
- // {
- default = config.nixfiles.modules.profiles.dev.enable;
- };
-
- config = mkIf cfg.enable {
- nixfiles.modules.common.shell.aliases = {
- h = "helm";
- k = "kubectl";
- kns = "kubens";
- ktx = "kubectx";
- };
-
- hm.home = {
- sessionVariables = {
- MINIKUBE_IN_STYLE = "false";
- WERF_DEV = "true";
- WERF_INSECURE_REGISTRY = "true";
- WERF_LOG_DEBUG = "true";
- WERF_LOG_PRETTY = "false";
- WERF_LOG_VERBOSE = "true";
- WERF_SYNCHRONIZATION = ":local";
- WERF_TELEMETRY = "false";
- };
-
- packages = with pkgs; [
- k9s
- kubectl
- kubectl-doctor
- kubectl-images
- kubectl-tree
- kubectx
- kubelogin-oidc
- kubent
- kubernetes-helm
- kubespy
- minikube
- skopeo
- stern
- telepresence2
- werf
- ];
- };
- };
-}