summaryrefslogtreecommitdiff
path: root/modules/common/profiles/dev/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/dev/default.nix')
-rw-r--r--modules/common/profiles/dev/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/modules/common/profiles/dev/default.nix b/modules/common/profiles/dev/default.nix
index 52dc49f..6ac1fe6 100644
--- a/modules/common/profiles/dev/default.nix
+++ b/modules/common/profiles/dev/default.nix
@@ -4,17 +4,18 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.profiles.dev;
-in {
+in
+{
imports = [
./containers.nix
./hidden.nix
./sql.nix
];
- options.nixfiles.modules.profiles.dev.enable =
- mkEnableOption "Catch-all profile for stuff related to software development and etc.";
+ options.nixfiles.modules.profiles.dev.enable = mkEnableOption "Catch-all profile for stuff related to software development and etc.";
config = mkIf cfg.enable {
nixfiles.modules = {