summaryrefslogtreecommitdiff
path: root/modules/common/profiles/dev/sql.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/dev/sql.nix')
-rw-r--r--modules/common/profiles/dev/sql.nix33
1 files changed, 16 insertions, 17 deletions
diff --git a/modules/common/profiles/dev/sql.nix b/modules/common/profiles/dev/sql.nix
index b290c16..3e1c4b2 100644
--- a/modules/common/profiles/dev/sql.nix
+++ b/modules/common/profiles/dev/sql.nix
@@ -16,7 +16,6 @@ in {
config = mkIf cfg.enable {
hm = {
home.packages = with pkgs; [
- dbeaver
pgcli
litecli
];
@@ -34,26 +33,26 @@ in {
table_format = "fancy_grid";
};
- colorsSection = with config.colourScheme; {
+ colorsSection = with config.colors.withHashtag; {
"arg-toolbar" = "noinherit bold";
"arg-toolbar.text" = "nobold";
- "bottom-toolbar" = "bg:${black} ${white}";
- "bottom-toolbar.off" = "bg:${black} ${brightBlack}";
- "bottom-toolbar.on" = "bg:${black} ${brightWhite}";
- "bottom-toolbar.transaction.failed" = "bg:${black} ${red} bold";
- "bottom-toolbar.transaction.valid" = "bg:${black} ${green} bold";
- "completion-menu.completion" = "bg:${black} ${white}";
- "completion-menu.completion.current" = "bg:${white} ${black}";
- "completion-menu.meta.completion" = "bg:${black} ${yellow}";
- "completion-menu.meta.completion.current" = "bg:${yellow} ${black}";
- "completion-menu.multi-column-meta" = "bg:${yellow} ${black}";
- "scrollbar" = "bg:${black}";
- "scrollbar.arrow" = "bg:${black}";
- "search" = "bg:${magenta} ${brightWhite}";
+ "bottom-toolbar" = "bg:${base01} ${base06}";
+ "bottom-toolbar.off" = "bg:${base01} ${base02}";
+ "bottom-toolbar.on" = "bg:${base01} ${base07}";
+ "bottom-toolbar.transaction.failed" = "bg:${base01} ${base08} bold";
+ "bottom-toolbar.transaction.valid" = "bg:${base01} ${base0B} bold";
+ "completion-menu.completion" = "bg:${base01} ${base06}";
+ "completion-menu.completion.current" = "bg:${base06} ${base01}";
+ "completion-menu.meta.completion" = "bg:${base01} ${base13}";
+ "completion-menu.meta.completion.current" = "bg:${base09} ${base01}";
+ "completion-menu.multi-column-meta" = "bg:${base09} ${base01}";
+ "scrollbar" = "bg:${base01}";
+ "scrollbar.arrow" = "bg:${base01}";
+ "search" = "bg:${base17} ${base07}";
"search-toolbar" = "noinherit bold";
"search-toolbar.text" = "nobold";
- "search.current" = "bg:${green} ${brightWhite}";
- "selected" = "bg:${blue} ${brightWhite}";
+ "search.current" = "bg:${base14} ${base07}";
+ "selected" = "bg:${base0D} ${base07}";
"system-toolbar" = "noinherit bold";
};