about summary refs log tree commit diff
path: root/modules/common/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/secrets.nix')
-rw-r--r--modules/common/secrets.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/modules/common/secrets.nix b/modules/common/secrets.nix
index 2b8082e..600b128 100644
--- a/modules/common/secrets.nix
+++ b/modules/common/secrets.nix
@@ -21,11 +21,9 @@
   config = {
     age.identityPaths =
       if this.isHeadful then
-        [ "${config.my.home}/.ssh/id_${lib.my.ssh.type}" ]
+        [ "${config.my.home}/.ssh/${this.hostname}_ed25519" ]
       else
-        config.services.openssh.hostKeys
-        |> lib.filter (attr: attr.type == lib.my.ssh.type)
-        |> map (attr: attr.path);
+        config.services.openssh.hostKeys |> lib.filter (x: x.type == "ed25519") |> map (x: x.path);
 
     environment.systemPackages = with pkgs; [
       age

Consider giving Nix/NixOS a try! <3