summaryrefslogtreecommitdiff
path: root/modules/common/vscode.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/vscode.nix')
-rw-r--r--modules/common/vscode.nix34
1 files changed, 7 insertions, 27 deletions
diff --git a/modules/common/vscode.nix b/modules/common/vscode.nix
index 6671973..92ce5b5 100644
--- a/modules/common/vscode.nix
+++ b/modules/common/vscode.nix
@@ -132,35 +132,15 @@ in {
git.allowForcePush = true;
- vim = let
- applyInputMethod = {
- "ibus" = let
- bin = "${pkgs.ibus}/bin/ibus";
- in {
- enable = true;
- defaultIM = "xkb:us::eng";
- obtainIMCmd = "${bin} engine";
- switchIMCmd = "${bin} engine {im}";
- };
- "fcitx" = let
- bin = "${pkgs.fcitx}/bin/fcitx-remote";
- in {
- enable = true;
- defaultIM = "1";
- obtainIMCmd = bin;
- switchIMCmd = "${bin} -t {im}";
- };
- };
- in
- mkIf cfg.vim.enable rec {
- easymotion = true;
- easymotionMarkerFontFamily = fontFamily;
- easymotionMarkerFontSize = fontSize;
+ vim = mkIf cfg.vim.enable rec {
+ easymotion = true;
+ easymotionMarkerFontFamily = fontFamily;
+ easymotionMarkerFontSize = fontSize;
- leader = " ";
+ leader = " ";
- useSystemClipboard = true;
- };
+ useSystemClipboard = true;
+ };
};
};
};