summaryrefslogtreecommitdiff
path: root/modules/common/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/zathura.nix')
-rw-r--r--modules/common/zathura.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/modules/common/zathura.nix b/modules/common/zathura.nix
index b13d2a6..bc92258 100644
--- a/modules/common/zathura.nix
+++ b/modules/common/zathura.nix
@@ -1,13 +1,10 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.zathura;
-in {
- options.nixfiles.modules.zathura.enable =
- mkEnableOption "Zathura PDF reader";
+in
+{
+ options.nixfiles.modules.zathura.enable = mkEnableOption "Zathura PDF reader";
config = mkIf cfg.enable {
hm.programs.zathura = {