summaryrefslogtreecommitdiff
path: root/modules/common/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/zathura.nix')
-rw-r--r--modules/common/zathura.nix80
1 files changed, 0 insertions, 80 deletions
diff --git a/modules/common/zathura.nix b/modules/common/zathura.nix
deleted file mode 100644
index bc92258..0000000
--- a/modules/common/zathura.nix
+++ /dev/null
@@ -1,80 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
- cfg = config.nixfiles.modules.zathura;
-in
-{
- options.nixfiles.modules.zathura.enable = mkEnableOption "Zathura PDF reader";
-
- config = mkIf cfg.enable {
- hm.programs.zathura = {
- enable = true;
-
- options = {
- recolor = true;
- recolor-keephue = false;
- recolor-reverse-video = false;
-
- highlight-transparency = "0.3";
-
- n-completion-items = 10;
-
- guioptions = "";
-
- statusbar-basename = true;
- statusbar-home-tilde = true;
-
- statusbar-h-padding = 0;
- statusbar-v-padding = 0;
-
- window-height = 800;
- window-width = 600;
-
- window-icon = "";
-
- abort-clear-search = true;
-
- incremental-search = true;
-
- adjust-open = "best-fit";
-
- advance-pages-per-row = false;
-
- database = "sqlite";
-
- dbus-service = false;
-
- page-padding = 0;
-
- pages-per-row = 1;
-
- render-loading = false;
-
- show-directories = true;
- show-hidden = true;
- show-recent = 10;
-
- link-zoom = true;
- link-hadjust = true;
-
- window-title-basename = true;
- window-title-home-tilde = true;
- window-title-page = true;
-
- zoom-center = false;
- zoom-max = 1000;
- zoom-min = 10;
- zoom-step = 10;
-
- scroll-hstep = -1;
- scroll-step = 40;
- scroll-full-overlap = 0;
- scroll-wrap = true;
- scroll-page-aware = false;
-
- selection-clipboard = "clipboard";
- selection-notification = false;
- };
- };
- };
-}