summaryrefslogtreecommitdiff
path: root/modules/darwin/common/xdg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/darwin/common/xdg.nix')
-rw-r--r--modules/darwin/common/xdg.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/modules/darwin/common/xdg.nix b/modules/darwin/common/xdg.nix
deleted file mode 100644
index 526dc0b..0000000
--- a/modules/darwin/common/xdg.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
- cfg = config.nixfiles.modules.common.xdg;
-in
-{
- hm.home.sessionVariables =
- with cfg;
- {
- XDG_CACHE_HOME = cacheHome;
- XDG_CONFIG_HOME = configHome;
- XDG_DATA_HOME = dataHome;
- XDG_STATE_HOME = stateHome;
- }
- // (with userDirs; {
- XDG_DOCUMENTS_DIR = documents;
- XDG_DOWNLOAD_DIR = download;
- XDG_MUSIC_DIR = music;
- XDG_PICTURES_DIR = pictures;
- XDG_PUBLICSHARE_DIR = publicShare;
- XDG_TEMPLATES_DIR = templates;
- XDG_VIDEOS_DIR = videos;
- });
-}