summaryrefslogtreecommitdiff
path: root/modules/darwin/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/darwin/emacs.nix')
-rw-r--r--modules/darwin/emacs.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/darwin/emacs.nix b/modules/darwin/emacs.nix
new file mode 100644
index 0000000..02bfb83
--- /dev/null
+++ b/modules/darwin/emacs.nix
@@ -0,0 +1,15 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.emacs;
+in {
+ config = mkIf cfg.enable {
+ # services.emacs = {
+ # enable = true;
+ # package = config.hm.programs.doom-emacs.package;
+ # };
+ };
+}