summaryrefslogtreecommitdiff
path: root/modules/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/emacs/default.nix')
-rw-r--r--modules/emacs/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/emacs/default.nix b/modules/emacs/default.nix
index 762c0a6..3e59ce8 100644
--- a/modules/emacs/default.nix
+++ b/modules/emacs/default.nix
@@ -135,13 +135,13 @@ in
pipenv # :lang python
poetry # :lang python
pre-commit # :tools magit
+ pyright # :lang python :editor format
python3 # :lang python
python3Packages.black # :lang python :editor format
python3Packages.isort # :lang python :editor format
python3Packages.nose2 # :lang python
python3Packages.pyflakes # :lang python :editor format
python3Packages.pytest # :lang python
- python3Packages.python-lsp-server # :lang python :editor format
ripgrep # doom!
rust-analyzer # :lang (rust +lsp)
rustc # :lang rust