summaryrefslogtreecommitdiff
path: root/modules/games/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/games/default.nix')
-rw-r--r--modules/games/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/games/default.nix b/modules/games/default.nix
new file mode 100644
index 0000000..dea9d3c
--- /dev/null
+++ b/modules/games/default.nix
@@ -0,0 +1,27 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.games;
+in
+{
+ imports = attrValues (modulesIn ./.);
+
+ options.nixfiles.modules.games.enable32BitSupport = mkEnableOption "support for games";
+
+ config = mkIf cfg.enable32BitSupport {
+ services = {
+ jack.alsa.support32Bit = config.services.jack.alsa.enable;
+
+ pipewire.alsa.support32Bit = config.services.pipewire.alsa.enable;
+ };
+
+ hardware = {
+ opengl = mkIf config.hardware.opengl.enable {
+ extraPackages32 = config.hardware.opengl.extraPackages;
+ driSupport32Bit = config.hardware.opengl.driSupport;
+ };
+
+ pulseaudio.support32Bit = config.hardware.pulseaudio.enable;
+ };
+ };
+}