about summary refs log tree commit diff
path: root/modules/games/gamemode.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/games/gamemode.nix')
-rw-r--r--modules/games/gamemode.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/games/gamemode.nix b/modules/games/gamemode.nix
index eb485f8..4e57a8b 100644
--- a/modules/games/gamemode.nix
+++ b/modules/games/gamemode.nix
@@ -1,13 +1,12 @@
 { config, lib, ... }:
-with lib;
 let
   cfg = config.nixfiles.modules.games.gamemode;
 in
 {
-  options.nixfiles.modules.games.gamemode.enable = mkEnableOption "Feral GameMode";
+  options.nixfiles.modules.games.gamemode.enable = lib.mkEnableOption "Feral GameMode";
 
-  config = mkIf cfg.enable {
-    hm.xdg.configFile."gamemode.ini".text = generators.toINI { } { general.softrealtime = "auto"; };
+  config = lib.mkIf cfg.enable {
+    hm.xdg.configFile."gamemode.ini".text = lib.generators.toINI { } { general.softrealtime = "auto"; };
 
     programs.gamemode.enable = true;
   };

Consider giving Nix/NixOS a try! <3