summaryrefslogtreecommitdiff
path: root/modules/games/mangohud.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/games/mangohud.nix')
-rw-r--r--modules/games/mangohud.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/games/mangohud.nix b/modules/games/mangohud.nix
new file mode 100644
index 0000000..955f50c
--- /dev/null
+++ b/modules/games/mangohud.nix
@@ -0,0 +1,28 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.games.mangohud;
+in
+{
+ options.nixfiles.modules.games.mangohud.enable = mkEnableOption "MangoHud";
+
+ config = mkIf cfg.enable {
+ hm = {
+ stylix.targets.mangohud.enable = false;
+
+ programs.mangohud = {
+ enable = true;
+ settings = {
+ fps = true;
+ frame_timing = true;
+ gpu_stats = true;
+ gpu_temp = true;
+ cpu_stats = true;
+ cpu_temp = true;
+ ram = true;
+ vram = true;
+ };
+ };
+ };
+ };
+}