summaryrefslogtreecommitdiff
path: root/modules/games/steam-run.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/games/steam-run.nix')
-rw-r--r--modules/games/steam-run.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/modules/games/steam-run.nix b/modules/games/steam-run.nix
index f6902c0..be06c78 100644
--- a/modules/games/steam-run.nix
+++ b/modules/games/steam-run.nix
@@ -2,6 +2,7 @@
config,
lib,
pkgs,
+ pkgsRev,
...
}:
with lib;
@@ -28,12 +29,8 @@ in
_:
with cfg.quirks;
optional blackIsleStudios openssl_1_0_0
- ++ optionals cryptOfTheNecrodancer [
- (import (builtins.fetchTarball {
- url = "https://github.com/NixOS/nixpkgs/archive/d1c3fea7ecbed758168787fe4e4a3157e52bc808.tar.gz";
- sha256 = "0ykm15a690v8lcqf2j899za3j6hak1rm3xixdxsx33nz7n3swsyy";
- }) { inherit (config.nixpkgs) config localSystem; }).flac
- ]
+ ++ optional cryptOfTheNecrodancer (pkgsRev "d1c3fea7ecbed758168787fe4e4a3157e52bc808" "sha256-3muuhz3fjtF1bz32UXOYCho51E8JSeEwo2iDZFQJdXo=")
+ .flac
++ optionals mountAndBladeWarband [
(glew.overrideAttrs (
_: super: