summaryrefslogtreecommitdiff
path: root/modules/jackett.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/jackett.nix')
-rw-r--r--modules/jackett.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/jackett.nix b/modules/jackett.nix
index 492e77a..07a5b16 100644
--- a/modules/jackett.nix
+++ b/modules/jackett.nix
@@ -1,7 +1,9 @@
{
config,
+ inputs,
lib,
libNginx,
+ this,
...
}:
with lib;
@@ -32,5 +34,14 @@ in
};
services.jackett.enable = true;
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.jackett = {
+ name = "Jackett";
+ icon = "${inputs.homelab-svg-assets}/assets/jackett.svg";
+ info = domain;
+ details.listen.text = "127.0.0.1:9117";
+ };
+ };
};
}