summaryrefslogtreecommitdiff
path: root/modules/lidarr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/lidarr.nix')
-rw-r--r--modules/lidarr.nix60
1 files changed, 60 insertions, 0 deletions
diff --git a/modules/lidarr.nix b/modules/lidarr.nix
new file mode 100644
index 0000000..84d363b
--- /dev/null
+++ b/modules/lidarr.nix
@@ -0,0 +1,60 @@
+{
+ config,
+ inputs,
+ lib,
+ libNginx,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.lidarr;
+in
+{
+ options.nixfiles.modules.lidarr = {
+ enable = mkEnableOption "Lidarr";
+
+ domain = mkOption {
+ description = "Domain name sans protocol scheme.";
+ type = with types; str;
+ default = "lidarr.${config.networking.domain}";
+ };
+ };
+
+ config = mkIf cfg.enable {
+ secrets.lidarr-api-key.file = "${inputs.self}/secrets/lidarr-api-key";
+
+ ark.directories = [ "/var/lib/lidarr" ];
+
+ nixfiles.modules.nginx = {
+ enable = true;
+ upstreams.lidarr.servers."127.0.0.1:8686" = { };
+ virtualHosts.${cfg.domain} = {
+ locations."/".proxyPass = "http://lidarr";
+ extraConfig = libNginx.config.internalOnly;
+ };
+ };
+
+ services = {
+ lidarr = {
+ enable = true;
+ user = "rtorrent";
+ group = "rtorrent";
+ };
+
+ prometheus.exporters.exportarr-lidarr = {
+ enable = true;
+ url = "http://127.0.0.1";
+ apiKeyFile = config.secrets.lidarr-api-key.path;
+ port = mkDefault 9708;
+ inherit (config.services.lidarr) user;
+ inherit (config.services.lidarr) group;
+ listenAddress = this.wireguard.ipv4.address;
+ environment.CONFIG = "/var/lib/lidarr/.config/Lidarr/config.xml";
+ };
+ };
+
+ systemd.tmpfiles.rules = with config.services.lidarr; [
+ "d /var/lib/lidarr/root 0755 ${user} ${group} - -"
+ ];
+ };
+}