summaryrefslogtreecommitdiff
path: root/modules/loki.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/loki.nix')
-rw-r--r--modules/loki.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/modules/loki.nix b/modules/loki.nix
index c446848..75e534b 100644
--- a/modules/loki.nix
+++ b/modules/loki.nix
@@ -2,6 +2,7 @@
config,
lib,
libNginx,
+ this,
...
}:
with lib;
@@ -120,5 +121,11 @@ in
"d ${storage.filesystem.chunks_directory} 0700 loki loki - -"
"d ${storage.filesystem.rules_directory} 0700 loki loki - -"
];
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.loki = {
+ info = domain;
+ };
+ };
};
}