summaryrefslogtreecommitdiff
path: root/modules/nixfiles/acme.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/acme.nix')
-rw-r--r--modules/nixfiles/acme.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/modules/nixfiles/acme.nix b/modules/nixfiles/acme.nix
deleted file mode 100644
index d3ad661..0000000
--- a/modules/nixfiles/acme.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
- cfg = config.nixfiles.modules.acme;
-in {
- imports = [
- (mkAliasOptionModule ["certs"] ["security" "acme" "certs"])
- ];
-
- options.nixfiles.modules.acme = {
- enable = mkEnableOption "ACME";
-
- email = mkOption {
- description = "Email for notifications.";
- type = with types; str;
- default = "admin+acme@${my.domain.shire}";
- };
- };
-
- config = mkIf cfg.enable {
- security.acme = {
- acceptTerms = true;
- defaults = {
- inherit (cfg) email;
- validMinDays = 60;
- };
- };
- };
-}