summaryrefslogtreecommitdiff
path: root/modules/nixfiles/common/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/common/users.nix')
-rw-r--r--modules/nixfiles/common/users.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/modules/nixfiles/common/users.nix b/modules/nixfiles/common/users.nix
index 0878db6..c761f55 100644
--- a/modules/nixfiles/common/users.nix
+++ b/modules/nixfiles/common/users.nix
@@ -6,12 +6,16 @@ with lib; {
mutableUsers = false;
users = {
+ # This will unset the root password so that it would be impossible to
+ # login as it directory. The root user will still be accessable via
+ # `sudo`.
root.hashedPassword = "[REDACTED]";
${my.username} = {
isNormalUser = true;
uid = 1000;
description = my.fullname;
+ # TODO Consider switching to passwordFile
inherit (my) hashedPassword;
openssh.authorizedKeys.keys = [my.ssh.key];
extraGroups = ["wheel"];