summaryrefslogtreecommitdiff
path: root/modules/nixfiles/common/xdg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/common/xdg.nix')
-rw-r--r--modules/nixfiles/common/xdg.nix67
1 files changed, 36 insertions, 31 deletions
diff --git a/modules/nixfiles/common/xdg.nix b/modules/nixfiles/common/xdg.nix
index 72a8e4c..60d5286 100644
--- a/modules/nixfiles/common/xdg.nix
+++ b/modules/nixfiles/common/xdg.nix
@@ -38,45 +38,50 @@ with lib; {
};
}
(mkIf this.isHeadful {
- mimeApps = let
- images = [
- "image/bmp"
- "image/gif"
- "image/jpeg"
- "image/jpg"
- "image/png"
- "image/svg+xml"
- "image/tiff"
- "image/webp"
- ];
- media = [
- "audio/aac"
- "audio/flac"
- "audio/mp3"
- "audio/ogg"
- "audio/wav"
- "audio/webm"
- "video/mkv"
- "video/mp4"
- "video/ogg"
- "video/webm"
- "video/x-matroska"
- ];
- in {
+ mimeApps = {
enable = true;
-
defaultApplications = mkMerge (mapAttrsToList
- (n: ms: genAttrs ms (_: ["${n}.desktop"]))
+ (n: v: genAttrs v (_: ["${n}.desktop"]))
{
- aria2 = ["application/x-bittorrent" "x-scheme-handler/magnet"];
- emacsclient = ["x-scheme-handler/mailto"];
+ emacsclient = [
+ "application/json"
+ "application/vnd.ms-publisher"
+ "application/x-desktop"
+ "application/x-shellscript"
+ "application/x-trash"
+ "application/x-wine-extension-ini"
+ "application/xml"
+ "text/markdown"
+ "text/plain"
+ ];
firefox = [
"text/html"
"x-scheme-handler/http"
"x-scheme-handler/https"
];
- gwenview = images;
- mpv = media;
+ gwenview = [
+ "image/bmp"
+ "image/gif"
+ "image/jpeg"
+ "image/jpg"
+ "image/png"
+ "image/svg+xml"
+ "image/tiff"
+ "image/webp"
+ ];
+ mpv = [
+ "audio/aac"
+ "audio/flac"
+ "audio/mp3"
+ "audio/ogg"
+ "audio/wav"
+ "audio/webm"
+ "video/mkv"
+ "video/mp4"
+ "video/ogg"
+ "video/webm"
+ "video/x-matroska"
+ ];
});
};
})