summaryrefslogtreecommitdiff
path: root/modules/nixfiles/firefox/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/firefox/default.nix')
-rw-r--r--modules/nixfiles/firefox/default.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/modules/nixfiles/firefox/default.nix b/modules/nixfiles/firefox/default.nix
index 6f4d327..8557d64 100644
--- a/modules/nixfiles/firefox/default.nix
+++ b/modules/nixfiles/firefox/default.nix
@@ -49,11 +49,11 @@ in {
'')
(with config.fontScheme; ''
--sans-serif-font-family: "${sansSerifFont.family}", "${sansSerifFontFallback.family}", sans-serif;
- --sans-serif-font-size: ${toString sansSerifFont.size};
+ --sans-serif-font-size: ${toString sansSerifFont.size}px;
--serif-font-family: "${serifFont.family}", "${serifFontFallback.family}", serif;
- --serif-font-size: ${toString serifFont.size};
+ --serif-font-size: ${toString serifFont.size}px;
--monospace-font-family: "${monospaceFont.family}", "${monospaceFontFallback.family}", monospace;
- --monospace-font-size: ${toString monospaceFont.size};
+ --monospace-font-size: ${toString monospaceFont.size}px;
}
'')
(builtins.readFile css)
@@ -66,7 +66,7 @@ in {
# A way to change the look of the Firefox itself.
userChrome = mkCssWithRoot ./userChrome.css;
- # A way to remove annoyances and visual bloat of many webpages.
+ # A way to remove annoyances and visual bloat from many webpages.
userContent = mkCssWithRoot ./userContent.css;
# https://github.com/arkenfox/user.js/blob/master/user.js
@@ -238,6 +238,7 @@ in {
settings = {
"app.update.auto" = false;
+ "browser.backspace_action" = 0;
"browser.bookmarks.max_backups" = 1;
"browser.disableResetPrompt" = true;
"browser.newtabpage.introShown" = true;
@@ -258,14 +259,17 @@ in {
"extensions.screenshots.disabled" = true;
"extensions.update.autoUpdateDefault" = false;
"extensions.update.enabled" = false;
+ "font.name-list.emoji" = "emoji";
"full-screen-api.warning.delay" = 0;
"full-screen-api.warning.timeout" = 0;
"general.autoScroll" = true;
"general.smoothScroll" = true;
+ "gfx.font_rendering.opentype_svg.enabled" = false;
"identity.fxaccounts.enabled" = false;
"media.autoplay.blocking_policy" = 2;
"media.autoplay.default" = 5;
"media.autoplay.enabled" = false;
+ "media.hardwaremediakeys.enabled" = false;
"reader.parse-on-load.enabled" = false;
"signon.rememberSignons" = false;
"toolkit.legacyUserProfileCustomizations.stylesheets" = true;
@@ -273,7 +277,6 @@ in {
};
extensions = with pkgs.nur.repos.rycee.firefox-addons;
- with config.nixfiles.modules;
[
bitwarden
consent-o-matic
@@ -284,7 +287,7 @@ in {
ublock-origin
violentmonkey
]
- ++ optional ipfs.enable ipfs-companion;
+ ++ optional config.nixfiles.modules.ipfs.enable ipfs-companion;
};
};