summaryrefslogtreecommitdiff
path: root/modules/nixfiles/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/git.nix')
-rw-r--r--modules/nixfiles/git.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/modules/nixfiles/git.nix b/modules/nixfiles/git.nix
index c7a2ba6..b121f8f 100644
--- a/modules/nixfiles/git.nix
+++ b/modules/nixfiles/git.nix
@@ -89,11 +89,19 @@ in {
}
// mapAttrs'
(n: v: nameValuePair ''url "git@${v}:"'' {insteadOf = "${n}:";}) {
+ "alpine" = "gitlab.alpinelinux.org";
"bitbucket" = "bitbucket.com";
"codeberg" = "codeberg.org";
+ "freedesktop" = "gitlab.freedesktop.org";
"github" = "github.com";
"gitlab" = "gitlab.com";
+ "gnome" = "gitlab.gnome.org";
+ "haskell" = "gitlab.haskell.org";
+ "kde" = "invent.kde.org";
+ "notabug" = "notabug.org";
+ "opencode" = "opencode.net";
"sourcehut" = "git.sr.ht";
+ "videolan" = "code.videolan.org";
};
aliases = let
@@ -138,12 +146,6 @@ in {
initExtra = mkAfter "_complete_alias gl __start_glab glab";
};
};
-
- xdg.configFile."glab-cli/aliases.yml".text = generators.toYAML {} {
- ci = "pipeline ci";
- co = "mr checkout";
- li = "ci lint";
- };
};
})
(mkIf cfg.server.enable {
@@ -187,6 +189,7 @@ in {
fastcgi_param QUERY_STRING $args;
fastcgi_param HTTP_HOST $server_name;
'';
+ # FIXME This breaks sources previewing for these files.
"~* ^/(.+.(ico|css|png))$".extraConfig = ''
alias ${cfg.server.package}/cgit/$1;
'';