summaryrefslogtreecommitdiff
path: root/modules/nixfiles/sonarr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/sonarr.nix')
-rw-r--r--modules/nixfiles/sonarr.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/modules/nixfiles/sonarr.nix b/modules/nixfiles/sonarr.nix
deleted file mode 100644
index 8c79175..0000000
--- a/modules/nixfiles/sonarr.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
- cfg = config.nixfiles.modules.sonarr;
-in {
- options.nixfiles.modules.sonarr = {
- enable = mkEnableOption "Sonarr";
-
- domain = mkOption {
- description = "Domain name sans protocol scheme.";
- type = with types; str;
- default = "sonarr.${config.networking.fqdn}";
- };
- };
-
- config = mkIf cfg.enable {
- nixfiles.modules.nginx = {
- enable = true;
- upstreams.sonarr.servers."127.0.0.1:8989" = {};
- virtualHosts.${cfg.domain}.locations."/".proxyPass = "http://sonarr";
- };
-
- services.sonarr.enable = true;
- };
-}