summaryrefslogtreecommitdiff
path: root/modules/nixfiles/throttled.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/throttled.nix')
-rw-r--r--modules/nixfiles/throttled.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/modules/nixfiles/throttled.nix b/modules/nixfiles/throttled.nix
index 2454ebd..f182ee1 100644
--- a/modules/nixfiles/throttled.nix
+++ b/modules/nixfiles/throttled.nix
@@ -10,6 +10,9 @@ in {
options.nixfiles.modules.throttled.enable = mkEnableOption "Throttled";
config = mkIf cfg.enable {
+ # Disable the module we are trying to "override".
+ services.throttled.enable = mkForce false;
+
environment.etc."throttled.conf".text = ''
[GENERAL]
# Enable or disable the script execution