summaryrefslogtreecommitdiff
path: root/modules/nixos/common/locale.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/common/locale.nix')
-rw-r--r--modules/nixos/common/locale.nix26
1 files changed, 15 insertions, 11 deletions
diff --git a/modules/nixos/common/locale.nix b/modules/nixos/common/locale.nix
index 7529996..09e0686 100644
--- a/modules/nixos/common/locale.nix
+++ b/modules/nixos/common/locale.nix
@@ -1,4 +1,8 @@
-{lib, ...}:
+{
+ lib,
+ pkgs,
+ ...
+}:
with lib; {
i18n = {
defaultLocale = mkDefault "en_GB.UTF-8";
@@ -9,22 +13,22 @@ with lib; {
"ja_JP.UTF-8/UTF-8"
"ru_RU.UTF-8/UTF-8"
];
+
+ inputMethod = {
+ enabled = "fcitx5";
+ fcitx5.addons = with pkgs; [
+ fcitx5-configtool
+ fcitx5-mozc
+ ];
+ };
};
services.xserver = {
- layout = concatStringsSep "," [
- "us"
- "ru"
- ];
- xkbVariant = concatStringsSep "," [
- ""
- "phonetic"
- ];
+ layout = "us";
xkbOptions = concatStringsSep "," [
- "terminate:ctrl_alt_bksp"
"caps:escape"
"compose:menu"
- "grp:win_space_toggle"
+ "terminate:ctrl_alt_bksp"
];
};
}