summaryrefslogtreecommitdiff
path: root/modules/nixos/common/locale.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/common/locale.nix')
-rw-r--r--modules/nixos/common/locale.nix18
1 files changed, 13 insertions, 5 deletions
diff --git a/modules/nixos/common/locale.nix b/modules/nixos/common/locale.nix
index 699f89b..0f79cb7 100644
--- a/modules/nixos/common/locale.nix
+++ b/modules/nixos/common/locale.nix
@@ -1,4 +1,9 @@
-{ lib, pkgs, ... }:
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
with lib;
{
i18n = {
@@ -13,10 +18,13 @@ with lib;
inputMethod = {
enabled = "fcitx5";
- fcitx5.addons = with pkgs; [
- fcitx5-configtool
- fcitx5-mozc
- ];
+ fcitx5 = {
+ addons = with pkgs; [
+ fcitx5-configtool
+ fcitx5-mozc
+ ];
+ waylandFrontend = config.nixfiles.modules.wayland.enable;
+ };
};
};