summaryrefslogtreecommitdiff
path: root/modules/nixos/common/locale.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/common/locale.nix')
-rw-r--r--modules/nixos/common/locale.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/modules/nixos/common/locale.nix b/modules/nixos/common/locale.nix
deleted file mode 100644
index 8b91a5a..0000000
--- a/modules/nixos/common/locale.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-{
- i18n = {
- defaultLocale = mkDefault "en_GB.UTF-8";
- supportedLocales = [
- "C.UTF-8/UTF-8"
- "en_GB.UTF-8/UTF-8"
- "en_US.UTF-8/UTF-8"
- "ja_JP.UTF-8/UTF-8"
- "ru_RU.UTF-8/UTF-8"
- ];
-
- inputMethod = {
- enabled = null; # FIXME Breaks on Wayland.
- fcitx5 = {
- addons = with pkgs; [
- fcitx5-configtool
- fcitx5-mozc
- ];
- waylandFrontend = config.nixfiles.modules.wayland.enable;
- };
- };
- };
-
- services.xserver.xkb = {
- layout = "us,ru";
- variant = ",phonetic";
- options = concatStringsSep "," [
- "caps:escape"
- "compose:menu"
- "grp:win_space_toggle"
- "terminate:ctrl_alt_bksp"
- ];
- };
-}