summaryrefslogtreecommitdiff
path: root/modules/nixos/common/xdg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/common/xdg.nix')
-rw-r--r--modules/nixos/common/xdg.nix20
1 files changed, 9 insertions, 11 deletions
diff --git a/modules/nixos/common/xdg.nix b/modules/nixos/common/xdg.nix
index 668996f..1fe167e 100644
--- a/modules/nixos/common/xdg.nix
+++ b/modules/nixos/common/xdg.nix
@@ -4,19 +4,19 @@
this,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.common.xdg;
-in {
+in
+{
options.nixfiles.modules.common.xdg.defaultApplications = mkOption {
description = "Default applications.";
type = with types; attrsOf (listOf str);
- default = {};
+ default = { };
};
config = {
- xdg.portal = mkIf this.isHeadful {
- enable = true;
- };
+ xdg.portal = mkIf this.isHeadful { enable = true; };
hm.xdg = mkMerge [
(with cfg; {
@@ -31,11 +31,9 @@ in {
(mkIf this.isHeadful {
mimeApps = {
enable = true;
- defaultApplications =
- mkMerge
- (mapAttrsToList
- (n: v: genAttrs v (_: ["${n}.desktop"]))
- cfg.defaultApplications);
+ defaultApplications = mkMerge (
+ mapAttrsToList (n: v: genAttrs v (_: [ "${n}.desktop" ])) cfg.defaultApplications
+ );
};
})
];