summaryrefslogtreecommitdiff
path: root/modules/nixos/endlessh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/endlessh.nix')
-rw-r--r--modules/nixos/endlessh.nix26
1 files changed, 14 insertions, 12 deletions
diff --git a/modules/nixos/endlessh.nix b/modules/nixos/endlessh.nix
index caf9a38..f1bf0bc 100644
--- a/modules/nixos/endlessh.nix
+++ b/modules/nixos/endlessh.nix
@@ -1,16 +1,15 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.endlessh;
-in {
+in
+{
options.nixfiles.modules.endlessh.enable = mkEnableOption "endlessh";
- config = let
- port = 22;
- in
+ config =
+ let
+ port = 22;
+ in
mkIf cfg.enable {
ark.directories = [
"/var/lib/gotify-server"
@@ -20,9 +19,12 @@ in {
services.endlessh = {
enable = true;
inherit port;
- extraOptions = ["-v" "-4"];
+ extraOptions = [
+ "-v"
+ "-4"
+ ];
};
- networking.firewall.allowedTCPPorts = [port];
+ networking.firewall.allowedTCPPorts = [ port ];
};
}