summaryrefslogtreecommitdiff
path: root/modules/nixos/endlessh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/endlessh.nix')
-rw-r--r--modules/nixos/endlessh.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/nixos/endlessh.nix b/modules/nixos/endlessh.nix
deleted file mode 100644
index f1bf0bc..0000000
--- a/modules/nixos/endlessh.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
- cfg = config.nixfiles.modules.endlessh;
-in
-{
- options.nixfiles.modules.endlessh.enable = mkEnableOption "endlessh";
-
- config =
- let
- port = 22;
- in
- mkIf cfg.enable {
- ark.directories = [
- "/var/lib/gotify-server"
- "/var/lib/private/gotify-server"
- ];
-
- services.endlessh = {
- enable = true;
- inherit port;
- extraOptions = [
- "-v"
- "-4"
- ];
- };
-
- networking.firewall.allowedTCPPorts = [ port ];
- };
-}