summaryrefslogtreecommitdiff
path: root/modules/nixos/games/gamemode.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/gamemode.nix')
-rw-r--r--modules/nixos/games/gamemode.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/nixos/games/gamemode.nix b/modules/nixos/games/gamemode.nix
new file mode 100644
index 0000000..051d12e
--- /dev/null
+++ b/modules/nixos/games/gamemode.nix
@@ -0,0 +1,13 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.games.gamemode;
+in {
+ options.nixfiles.modules.games.gamemode.enable =
+ mkEnableOption "Feral GameMode";
+
+ config = mkIf cfg.enable {programs.gamemode.enable = true;};
+}