summaryrefslogtreecommitdiff
path: root/modules/nixos/games/gog.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/gog.nix')
-rw-r--r--modules/nixos/games/gog.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/nixos/games/gog.nix b/modules/nixos/games/gog.nix
new file mode 100644
index 0000000..86039f1
--- /dev/null
+++ b/modules/nixos/games/gog.nix
@@ -0,0 +1,18 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.games.gog;
+in {
+ options.nixfiles.modules.games.gog.enable =
+ mkEnableOption "stand-alone GOG clients and the ability to run GOG games";
+
+ config = mkIf cfg.enable {
+ nixfiles.modules.games.steam-run.enable = true;
+
+ hm.home.packages = with pkgs; [lgogdownloader];
+ };
+}