summaryrefslogtreecommitdiff
path: root/modules/nixos/games/mangohud.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/mangohud.nix')
-rw-r--r--modules/nixos/games/mangohud.nix26
1 files changed, 15 insertions, 11 deletions
diff --git a/modules/nixos/games/mangohud.nix b/modules/nixos/games/mangohud.nix
index d693c82..509e035 100644
--- a/modules/nixos/games/mangohud.nix
+++ b/modules/nixos/games/mangohud.nix
@@ -9,17 +9,21 @@ in {
options.nixfiles.modules.games.mangohud.enable = mkEnableOption "MangoHud";
config = mkIf cfg.enable {
- hm.programs.mangohud = {
- enable = true;
- settings = {
- fps = true;
- frame_timing = true;
- gpu_stats = true;
- gpu_temp = true;
- cpu_stats = true;
- cpu_temp = true;
- ram = true;
- vram = true;
+ hm = {
+ stylix.targets.mangohud.enable = false;
+
+ programs.mangohud = {
+ enable = true;
+ settings = {
+ fps = true;
+ frame_timing = true;
+ gpu_stats = true;
+ gpu_temp = true;
+ cpu_stats = true;
+ cpu_temp = true;
+ ram = true;
+ vram = true;
+ };
};
};
};