about summary refs log tree commit diff
path: root/modules/nixos/games/steam.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/steam.nix')
-rw-r--r--modules/nixos/games/steam.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/modules/nixos/games/steam.nix b/modules/nixos/games/steam.nix
deleted file mode 100644
index 5883b0e..0000000
--- a/modules/nixos/games/steam.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
-}:
-with lib;
-let
-  cfg = config.nixfiles.modules.games.steam;
-in
-{
-  options.nixfiles.modules.games.steam.enable = mkEnableOption "Steam runtime";
-
-  config = mkIf cfg.enable {
-    nixfiles.modules = {
-      common.nix.allowedUnfreePackages = [
-        "steam"
-        "steam-original"
-      ];
-
-      games = {
-        enable32BitSupport = true;
-        gamemode.enable = true;
-        mangohud.enable = true;
-      };
-    };
-
-    hm.home.packages = with pkgs; [
-      (steam.override { extraEnv.MANGOHUD = 1; })
-      protontricks
-    ];
-  };
-}

Consider giving Nix/NixOS a try! <3