summaryrefslogtreecommitdiff
path: root/modules/nixos/git/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/git/default.nix')
-rw-r--r--modules/nixos/git/default.nix57
1 files changed, 3 insertions, 54 deletions
diff --git a/modules/nixos/git/default.nix b/modules/nixos/git/default.nix
index 86891ae..1bf63c7 100644
--- a/modules/nixos/git/default.nix
+++ b/modules/nixos/git/default.nix
@@ -20,7 +20,7 @@ in {
package = mkOption {
description = "Package.";
type = types.package;
- default = pkgs.cgit-pink;
+ default = pkgs.cgit;
};
};
@@ -58,6 +58,8 @@ in {
root-desc=Homo sum, humani a me nihil alienum puto.
footer=
+ clone-url=https://${cfg.server.domain}/$CGIT_REPO_URL
+
logo=/cgit-custom-logo.gif
favicon=/cgit-custom-favicon.gif
css=/cgit-custom-style.css
@@ -68,7 +70,6 @@ in {
enable-git-config=1
enable-gitweb-owner=1
- enable-index-owner=0
remove-suffix=1
readme=:README
@@ -106,63 +107,11 @@ in {
pkgs.writeText "custom.css" ''
@import url("cgit.css");
- form {
- display: none;
- }
-
div#cgit {
- max-width: 157ch;
- margin: auto;
font-family: "${config.fontScheme.monospaceFont.family}", monospace;
-moz-tab-size: 4;
tab-size: 4;
}
-
- div#cgit table#header td.sub {
- border-top: none;
- }
-
- div#cgit table#header td.sub.right {
- padding-right: 1em;
- }
-
- div#cgit table.tabs {
- border-bottom: none;
- }
-
- div#cgit div.content {
- border-bottom: none;
- }
-
- div#cgit table.list th a {
- color: inherit;
- }
-
- div#cgit table.list tr:nth-child(even) {
- background: inherit;
- }
-
- div#cgit table.list tr:hover {
- background: inherit;
- }
-
- div#cgit table.list tr.nohover-highlight:hover:nth-child(even) {
- background: inherit;
- }
-
- div#cgit table.blob td.linenumbers a:target {
- color: goldenrod;
- text-decoration: underline;
- outline: none;
- }
-
- div#cgit div#summary {
- max-width: 80ch;
- }
-
- div#cgit a.permalink {
- color: inherit;
- }
'';
in ''
alias ${css};