summaryrefslogtreecommitdiff
path: root/modules/nixos/gnupg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/gnupg.nix')
-rw-r--r--modules/nixos/gnupg.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/modules/nixos/gnupg.nix b/modules/nixos/gnupg.nix
new file mode 100644
index 0000000..b86be9b
--- /dev/null
+++ b/modules/nixos/gnupg.nix
@@ -0,0 +1,38 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.gnupg;
+in {
+ options.nixfiles.modules.gnupg.pinentry = mkOption {
+ description = "Name of a pinentry implementation.";
+ type = types.str;
+ default = "curses";
+ };
+
+ config = mkIf cfg.enable {
+ hm = {
+ programs.gpg.homedir = "${config.dirs.data}/gnupg";
+
+ services.gpg-agent = {
+ enable = true;
+
+ enableSshSupport = true;
+ enableScDaemon = false;
+
+ defaultCacheTtl = 999999;
+ defaultCacheTtlSsh = 999999;
+ maxCacheTtl = 999999;
+ maxCacheTtlSsh = 999999;
+
+ grabKeyboardAndMouse = true;
+
+ sshKeys = [my.pgp.grip];
+
+ pinentryFlavor = cfg.pinentry;
+ };
+ };
+ };
+}