summaryrefslogtreecommitdiff
path: root/modules/nixos/gnupg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/gnupg.nix')
-rw-r--r--modules/nixos/gnupg.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/modules/nixos/gnupg.nix b/modules/nixos/gnupg.nix
index b86be9b..5300554 100644
--- a/modules/nixos/gnupg.nix
+++ b/modules/nixos/gnupg.nix
@@ -1,6 +1,7 @@
{
config,
lib,
+ pkgs,
...
}:
with lib; let
@@ -8,8 +9,8 @@ with lib; let
in {
options.nixfiles.modules.gnupg.pinentry = mkOption {
description = "Name of a pinentry implementation.";
- type = types.str;
- default = "curses";
+ type = types.package;
+ default = pkgs.pinentry-curses;
};
config = mkIf cfg.enable {
@@ -31,7 +32,7 @@ in {
sshKeys = [my.pgp.grip];
- pinentryFlavor = cfg.pinentry;
+ pinentryPackage = cfg.pinentry;
};
};
};