summaryrefslogtreecommitdiff
path: root/modules/nixos/nullmailer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/nullmailer.nix')
-rw-r--r--modules/nixos/nullmailer.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/nixos/nullmailer.nix b/modules/nixos/nullmailer.nix
deleted file mode 100644
index 9f7b4ac..0000000
--- a/modules/nixos/nullmailer.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{
- config,
- inputs,
- lib,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.nullmailer;
-in
-{
- options.nixfiles.modules.nullmailer.enable = mkEnableOption "Nullmailer";
-
- config = mkIf cfg.enable {
- # No use in enabling it other than having a retry queue.
- # ark.directories = ["/var/spool/nullmailer"];
-
- secrets.nullmailer-remotes = with config.services.nullmailer; {
- file = "${inputs.self}/secrets/nullmailer-remotes";
- owner = user;
- inherit group;
- };
-
- services.nullmailer = {
- enable = true;
- remotesFile = config.secrets.nullmailer-remotes.path;
- config.me = config.networking.domain;
- };
- };
-}