summaryrefslogtreecommitdiff
path: root/modules/nixos/podman.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/podman.nix')
-rw-r--r--modules/nixos/podman.nix54
1 files changed, 22 insertions, 32 deletions
diff --git a/modules/nixos/podman.nix b/modules/nixos/podman.nix
index 0f6db48..f6ee6bf 100644
--- a/modules/nixos/podman.nix
+++ b/modules/nixos/podman.nix
@@ -18,6 +18,8 @@ in {
}
];
+ nixfiles.modules.common.shell.aliases.p = "podman";
+
secrets.containers-auth = {
file = "${inputs.self}/secrets/containers-auth";
path = "${config.dirs.config}/containers/auth.json";
@@ -31,38 +33,26 @@ in {
my.extraGroups = ["podman"];
- hm = {
- xdg.configFile = {
- # This removes a really annoying registry search. 100% of the time I
- # would need to look up stuff from the Docker and not Quay!
- "containers/registries.conf".text = ''
- [registries.search]
- registries = ["docker.io"]
- '';
-
- # As for plain OverlayFS in Podman over ZFS[1]... I guess we are waiting
- # for Podman to catch up now.
- #
- # [1]: https://github.com/openzfs/zfs/pull/14070#issuecomment-1309116666
- "containers/storage.conf".text = optionalString config.boot.zfs.enabled ''
- [storage]
- driver = "overlay"
-
- [storage.options]
- mount_program = "${getExe' pkgs.fuse-overlayfs "fuse-overlayfs"}"
- mountopt = "noatime,nodev,nosuid"
- '';
- };
-
- programs.bash = {
- shellAliases = {
- podman = "grc -es ${getExe' pkgs.podman "podman"}";
- p = "podman";
- };
- initExtra = mkAfter ''
- _complete_alias p __start_podman podman
- '';
- };
+ hm.xdg.configFile = {
+ # This removes a really annoying registry search. 100% of the time I
+ # would need to look up stuff from the Docker and not Quay!
+ "containers/registries.conf".text = ''
+ [registries.search]
+ registries = ["docker.io"]
+ '';
+
+ # As for plain OverlayFS in Podman over ZFS[1]... I guess we are waiting
+ # for Podman to catch up now.
+ #
+ # [1]: https://github.com/openzfs/zfs/pull/14070#issuecomment-1309116666
+ "containers/storage.conf".text = optionalString config.boot.zfs.enabled ''
+ [storage]
+ driver = "overlay"
+
+ [storage.options]
+ mount_program = "${getExe' pkgs.fuse-overlayfs "fuse-overlayfs"}"
+ mountopt = "noatime,nodev,nosuid"
+ '';
};
};
}