summaryrefslogtreecommitdiff
path: root/modules/nixos/prometheus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/prometheus.nix')
-rw-r--r--modules/nixos/prometheus.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/modules/nixos/prometheus.nix b/modules/nixos/prometheus.nix
new file mode 100644
index 0000000..a75c151
--- /dev/null
+++ b/modules/nixos/prometheus.nix
@@ -0,0 +1,49 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.prometheus;
+in {
+ options.nixfiles.modules.prometheus = {
+ enable = mkEnableOption "Prometheus";
+
+ port = mkOption {
+ description = "Port.";
+ type = with types; port;
+ default = 30111;
+ };
+
+ domain = mkOption {
+ description = "Domain name sans protocol scheme.";
+ type = with types; str;
+ default = "prometheus.${config.networking.domain}";
+ };
+ };
+
+ config = mkIf cfg.enable {
+ nixfiles.modules.nginx = with cfg; {
+ enable = true;
+ upstreams.prometheus.servers."127.0.0.1:${toString cfg.port}" = {};
+ virtualHosts.${domain} = {
+ locations."/".proxyPass = "http://prometheus";
+ extraConfig = nginxInternalOnly;
+ };
+ };
+
+ services.prometheus = with cfg; {
+ enable = true;
+
+ listenAddress = "127.0.0.1";
+ inherit port;
+
+ extraFlags = [
+ "--web.external-url=https://${domain}"
+ "--storage.tsdb.retention.size=50GB"
+ "--storage.tsdb.retention.time=1y"
+ "--storage.tsdb.wal-compression"
+ ];
+ };
+ };
+}