summaryrefslogtreecommitdiff
path: root/modules/nixos/rtorrent.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/rtorrent.nix')
-rw-r--r--modules/nixos/rtorrent.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/modules/nixos/rtorrent.nix b/modules/nixos/rtorrent.nix
index a4cade7..5d2dba5 100644
--- a/modules/nixos/rtorrent.nix
+++ b/modules/nixos/rtorrent.nix
@@ -1,6 +1,7 @@
{
config,
lib,
+ libNginx,
pkgs,
...
}:
@@ -225,13 +226,10 @@ in {
"/".tryFiles = "$uri /index.html";
"/api" = {
proxyPass = "http://flood";
- extraConfig = ''
- proxy_buffering off;
- proxy_cache off;
- '';
+ extraConfig = libNginx.config.noProxyBuffering;
};
};
- extraConfig = nginxInternalOnly;
+ extraConfig = libNginx.config.internalOnly;
};
};