summaryrefslogtreecommitdiff
path: root/modules/nixos/sonarr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/sonarr.nix')
-rw-r--r--modules/nixos/sonarr.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/nixos/sonarr.nix b/modules/nixos/sonarr.nix
new file mode 100644
index 0000000..8c79175
--- /dev/null
+++ b/modules/nixos/sonarr.nix
@@ -0,0 +1,28 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.sonarr;
+in {
+ options.nixfiles.modules.sonarr = {
+ enable = mkEnableOption "Sonarr";
+
+ domain = mkOption {
+ description = "Domain name sans protocol scheme.";
+ type = with types; str;
+ default = "sonarr.${config.networking.fqdn}";
+ };
+ };
+
+ config = mkIf cfg.enable {
+ nixfiles.modules.nginx = {
+ enable = true;
+ upstreams.sonarr.servers."127.0.0.1:8989" = {};
+ virtualHosts.${cfg.domain}.locations."/".proxyPass = "http://sonarr";
+ };
+
+ services.sonarr.enable = true;
+ };
+}