summaryrefslogtreecommitdiff
path: root/modules/nixos/throttled.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/throttled.nix')
-rw-r--r--modules/nixos/throttled.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/modules/nixos/throttled.nix b/modules/nixos/throttled.nix
index eca803b..7d37cd4 100644
--- a/modules/nixos/throttled.nix
+++ b/modules/nixos/throttled.nix
@@ -1,11 +1,9 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.throttled;
-in {
+in
+{
options.nixfiles.modules.throttled.enable = mkEnableOption "Throttled";
config = mkIf cfg.enable {